WEBサーバーnginxのキャッシュで失敗した設定 proxy_cache fastcgi_temp
みなさん、こんにちは武智建樹です。
最近、暇があればnginxをポチポチ触っていろいろな設定を自分の目で見て楽しんでいます。
さて、今回はnginxのキャッシュに挑戦してみました。
wordpressの高速化!キャッシュについてのアレコレを参考に
バックグラウンドにapacheを使用したproxy_cacheや、php-fpmを使用したfastcgi_tempを
試してみました。
今までキャッシュファイルを作成するキャッシュ方法はあまり好きではありませんでした。
(ディスクアクセスによる遅延が発生しそうなので・・・)
ので、ついでにHDD・SSD?より高速なメモリディスクを利用したキャッシュ設定を試してみました。
最近のLinux OSでは、標準でメモリディスクが設定されているのかな?
tmpfs /dev/shm
デフォルトの/dev/shmをそのままnginxのキャッシュ置場として設定してもいいのですが
nginxのキャッシュを一瞬で削除したりしたいので、他のシステムのファイルが混合しないように
nginx専用のtmpfsを新しく作成しました。
/etc/fstab
------------------------------
↓ 追加
tmpfs /var/cache/nginx tmpfs defaults,noatime,mode=1777,size=256m 0 0
------------------------------
特に難しい設定もなくproxy_cacheやfastcgi_tempフォルダに、各キャッシュファイルがどんどん作成されていきます。
ブラウザーで確認してみると、数100倍くらいレスポンスが良くなっているのを確認できます。
しばらく様子を見ていると、ページが真っ白になって何も表示されない不具合に遭遇。あれ?
エラーファイルを確認すると、キャッシュが作成できないエラーが大量発生中・・・
なるほど!ディスクの空き容量がなくなると、古いファイルから自動で削除されるものだと
思っていました。(都合良すぎです。nginxに関係ないですもんね)
sizeを%で設定した方が良いのかな?
大容量のメモリーを搭載しているサーバーなら数GBを設定しておけば良いし
サイトのページ数(ボリューム)とキャッシュの有効期限を調整してみるのもいいかもしれませんね。
関連記事
メールエラー Maximum number of connections from user+IP exceeded
Maximum number of connections from user+IP exceeded (mail_max_userip_connections) スマートフォン、タブレット、ノートパソコンなど、複数のモ […]
Youtubeで再生される動画をデフォルトで高画質に設定 Auto HD For YouTube
製品などの説明を探している際に 最近良くYoutube動画へリンクされている場合があります。 検索エンジンでページを検索した場合、いくつも関連するページが表示されますよね。 されと同じでYoutube内で検索すると関連す […]
WordPress 無限ループのリダイレクトエラー・不具合を解決する方法
前までは普通に使えていたWordpressがある時から、無限ループでリダイレクトエラーになってしまう。 (サーバーを変更したのが原因?) 管理画面にログインした状態だとリダイレクトエラーになっていました。 ログインしてい […]
Adobe Premire Proのモニター画面が真っ黒になったり反転したりの不具合
久しぶりにAdobe Premire Pro 6.5を起動したところ、ソースモニタなどプレビュー映像を表示する箇所が、真っ黒のまま再生されない不具合になっていました。 いろいろなソフトをインストールしていたので その影響 […]
windows10 不明なコマンドラインエラー/DynamicUpdateが修正できない
いやはや年末で仕事おさめという中、最後の最後でパソコントラブルがなおらないとは・・・ Windows10恐るべし! 新しいパソコンを用意してWindows10を直接クリーンインストールできたのに ライセンス認証ができない […]
Google ChromeとjQuery1.10.2でevent.returnValueエラーがでる wordpress
あれ?前までは表示されていなかった下記のようなエラーが Chromeのコンソール画面に出力されるようになっていた。 event.returnValue is deprecated. Please use the stan […]